Hatena::Groupnadesiko2

mr-80bの日記

2011-07-09

monoでnadesiko2にチャレンジ

23:34

とりあえず、先日作ったfizzbuzzのプログラムは動いたっぽい\(^O^)/

# mono cnako2.exe fizzbuzz.nako
1
2
fizz
4
buzz
fizz
7
8
fizz
buzz
11
fizz
13
14
fizzbuzz
16
17
fizz
19
buzz
fizz
22
23
fizz
buzz
26
fizz
28
29
fizzbuzz
31
32
fizz
34
buzz
fizz
37
38
fizz
buzz
41
fizz
43
44
fizzbuzz
46
47
fizz
49
buzz
fizz
52
53
fizz
buzz
56
fizz
58
59
fizzbuzz
61
62
fizz
64
buzz
fizz
67
68
fizz
buzz
71
fizz
73
74
fizzbuzz
76
77
fizz
79
buzz
fizz
82
83
fizz
buzz
86
fizz
88
89
fizzbuzz
91
92
fizz
94
buzz
fizz
97
98
fizz
buzz

環境設定メモ

23:22

2011-07-02

開発者ミーティング(オフライン)

17:02

成果
  • ソースコミット(U_Dさん)
    • 正規表現関係
メモ
  • 開発コンセプト
    • より雅な日本語プログラミング言語
TODO
  • MONOにトライ
    • 椿ウィキ
  • C#の本買う
  • なでしこ2のエディタ
    • ソーシャルネットワーク
    • ソーシャルゲーム(バッヂ?)
    • コード共有?
    • チャット?
アイデア
  • 初心者と上級者をわけて扱う
  • 初心者用命令、上級者用命令にわける
  • 初心者モードでは、表現も限定する
・・・で、プロジェクト0.5は達成できそうなのか?

・・・

なでしこ2でfizzbuzz

17:01

F=0
Xで1から100まで繰り返す
 もし、X%3=0ならば
  「fizz」と継続表示
  F=1
 もし、X%5=0ならば
  「buzz」と継続表示
  F=1
 もし、F=0ならば
  Xを継続表示
 F=0
 「」と表示

AdonicaAdonica2011/11/24 21:06Call me wind becusae I am absolutely blown away.

ghceksjjsghceksjjs2011/11/26 23:443NwFLc <a href="http://ycmvuvphdydo.com/">ycmvuvphdydo</a>

2011-05-01

【週刊プロジェクト0.5-Vol.0】やってみようと思います

22:39

--------------------------------------------------

【週刊プロジェクト0.5-Vol.0】やってみようと思います

---------------------------------------------------

こんばんは。はやしまです。

突然ですが、なでしこ2の開発を盛り上げていく事をめざした活動の一環として

「週刊プロジェクト0.5」というタイトルで、メルマガっぽい感じのメールを

週一のペースでこのMLに投稿してみたいと考えました。

■「プロジェクト0.5」とは

はやしまが勝手に考えたもの(笑)

目的:2011年夏ぐらいまでに、なでしこ2 V0.5のリリースを目指す!

V0.5で目指すレベルのイメージ:CNAKOベース。基本的な文法を実装。

■「週刊プロジェクト0.5」について

発行者:はやしま

期限:未定(なでしこ2 V0.5がリリースされるまで)

発行ペース:週に1回週末(毎週土曜か日曜)を基本。

 (例外的に臨時号を発行することもあるかも)

■最近のトピック

・4/16 OSC2011Kansai@Kobeに出展。その後の喫茶店MTGで、なでしこ2について

 熱く語り合う!

・粗茶さんがなでしこ2のコミッタとして参加! [nadesiko-dev :640]

・しらたまさんよりなでしこ2についての考察が公開 [nadesiko-dev :643]

 http://nadesiko.g.hatena.ne.jp/white-ball/20110420

■開発者ミーティングについて検討中

時期:6月後半か7月前半の土日のいずれか

   候補日:6/25(土) or 7/2(土)

場所:関西

内容案:第一部:プレゼンの部

    第二部:アイデアブレストの部

    第三部:みんなで作業の部

プレゼンのテーマ(例):

 「こんな、なでしこが欲しい!」

 「なでしこ2の仕組み」

 「プラグインの作り方」

 「なでしこ+スマートフォンを考えてみた」

ブレストのテーマ(例):

 ・こんなツールを付属したら流行る!

 ・こうしたら、使いたくなる!

 ・こんな機能があれば面白い!

 ・災害時になでしこを役立てるのに必要なのは?

 ・なでしこを使えばモテると言われるために必要なのは?

■その他のコミュニケーションについての検討

オンラインミーティング

・テキスト(チャット)

・音声(Skype

■仕様について

[検討中]

・オブジェクト指向を採用するかどうか

■その他考えたいこと

・仕様に関する意志決定方式

 (コンセンサスの取り方、クジラさんの承認の取り方など)

ML運用について

 (オープンな議論の場の必要性)


----------------------------

[あとがき]

とりあえず勢いで Vol.0 という形で作ってみました。

今後については(継続するかどうかも含め)みなさんからの反応、状況など

みながら考えたいと思います。そういう意味ではみなさんから反応いただけるこ

とは重要な要素なので、ちょっとした事、細かい事でもどんどん反応いただける

と幸いです。(はやしま)

----------------------------

2010-10-23

SharpDevelop 4.0 Beta 3

23:21

おくればせながらSharpDevelop 4.0 Beta 3をインストール。

2010-10-03

なでしこ2開発状況ウォッチ 2010/10/3

22:43

  • その他
    • なでしこ2.0のプラグイン作成 - 粗茶@なでしこの日記 - なでしこ学習帳@はてな
    • http://nadesiko.g.hatena.ne.jp/nade_socha/20101002
      • 粗茶さんがプラグイン作成についてのエントリを書かれています。

動きがあってうれしい!